erika build error

Forum related to ERIKA Enterprise and RT-Druid version 2

Moderator: paolo.gai

Post Reply
shakthi
Newbie
Posts: 11
Joined: Mon Nov 12, 2018 9:24 pm

erika build error

Post by shakthi » Thu Nov 15, 2018 6:24 pm

please let me know how to clear the following error in the attachment provided and also how to proceed from there on...
Attachments
error while building
error while building
ERROR_juno.png (142.62 KiB) Viewed 4326 times

paolo.gai
Administrator
Posts: 864
Joined: Thu Dec 07, 2006 12:11 pm

Re: erika build error

Post by paolo.gai » Thu Nov 15, 2018 9:49 pm

Dear Sir,

It would be kind if, when someone is asking for help, also tells who he/she is, provide his/her name, and a bit of context in the e-mail...

Anyway, the error you are having is quite clear and is in the console message.

did you try following the tutorial?

http://erika.tuxfamily.org/wiki/index.p ... on_Windows

And, if it still does not work for you, please download the virtual machine and use it. it is already pre-configured.

PJ

shakthi
Newbie
Posts: 11
Joined: Mon Nov 12, 2018 9:24 pm

Re: erika build error

Post by shakthi » Sun Nov 18, 2018 5:31 pm

hi sir, i am shakthi ..when i try to build the project
Attachments
error_juno2.png
error_juno2.png (142.26 KiB) Viewed 4317 times

shakthi
Newbie
Posts: 11
Joined: Mon Nov 12, 2018 9:24 pm

erika2 build error

Post by shakthi » Mon Nov 19, 2018 5:00 pm

hi sir i am getting this error when i tried to build the project.....

Also tell me how to clear this error as i couldnot able to understand your tutorials
Attachments
error_juno2.png
error_juno2.png (142.26 KiB) Viewed 4309 times

paolo.gai
Administrator
Posts: 864
Joined: Thu Dec 07, 2006 12:11 pm

Re: erika2 build error

Post by paolo.gai » Tue Nov 20, 2018 7:34 am

Dear shakthi,

Please use the virtual machine we provide in the download page. It is already pre-configured.

The problem you have is likely a misconfiguration of the compiler. Did you filled up the Arduino SDK property in the Windows/Preferences/Oil/Generator properties?

Finally, please follow the following wiki:
http://www.erika-enterprise.com/wiki/in ... on_Windows

Ciao,

PJ

shakthi
Newbie
Posts: 11
Joined: Mon Nov 12, 2018 9:24 pm

Re: erika build error

Post by shakthi » Sat Nov 24, 2018 12:45 pm

hi , i have connected arduino board but its not connecting in the virtual machine
also i have installed extension pack for the usb controllers
Attachments
vmerror.png
vmerror.png (1.34 MiB) Viewed 4297 times

paolo.gai
Administrator
Posts: 864
Joined: Thu Dec 07, 2006 12:11 pm

Re: erika build error

Post by paolo.gai » Sat Nov 24, 2018 5:07 pm

it means the device is in use by another process. Try closing the other processes, reblooting, or remopving/reinserting the board...

PJ

shakthi
Newbie
Posts: 11
Joined: Mon Nov 12, 2018 9:24 pm

Re: erika build error

Post by shakthi » Sun Nov 25, 2018 8:49 pm

hi palo gai, i have reset the arduino but still its showing the fail to connect message.

i am using arduino uno basic board.

whether i have to install something in virtual machine to detect the board????

paolo.gai
Administrator
Posts: 864
Joined: Thu Dec 07, 2006 12:11 pm

Re: erika build error

Post by paolo.gai » Tue Nov 27, 2018 9:11 am

In general, no. The virtual machine should be able to detect the USB. If it is saying that someone else is using the board, it means maybe you have opened the Arduino interface.

On the previous issue you had related to the makefile, are you sure that when you created the project on ERIKA3 you selected "Cygwin" toolchain?

PJ

shakthi
Newbie
Posts: 11
Joined: Mon Nov 12, 2018 9:24 pm

Re: erika build error

Post by shakthi » Tue Nov 27, 2018 7:37 pm

sir, please tell me then how can i able to make the board attach to the virtual machine....

shakthi
Newbie
Posts: 11
Joined: Mon Nov 12, 2018 9:24 pm

Re: erika build error

Post by shakthi » Tue Nov 27, 2018 7:37 pm

sir, please tell me then how can i able to make the board attach to the virtual machine....

Post Reply