amazing ball_problema di compilazione

Forum relativo alle schede FLEX, ERIKA Enterprise, RT-Druid, ScicosLab, ...

Moderator: paolo.gai

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

amazing ball_problema di compilazione

Post by bongini89 » Fri Nov 06, 2015 7:05 pm

Buona sera.

Sono uno studente di ingegneria e come progetto per sostenere l'esame di automatica mi hanno assegnato il ball and plate.

Sto lavorando con lo scicoslab_pack_11.1, seguendo le istruzioni all'interno del pdf del pacchetto ho istallato nell'ordine:

- scicoslab 4.4.1, che ha creato la cartella con il seguente percorso C:\Program Files\scicoslab-4.4.1
- microsoft visual c++ 2008 express, che ha creato la cartella con il seguente percorso C:\Program Files (x86)\Microsoft Visual Studio 9.0
- mplab ide, che ha creato la cartella con il seguente percorso C:\Program Files (x86)\Microchip\MPLAB IDE
- c 30 compiler, che ha creato la cartella con il seguente percorso C:\Program Files (x86)\Microchip\MPLAB C30
- cygwing, che ha creato la cartella con il seguente percorso C:\cygwin
- JRE (java routine enviroment), che ha creato la cartella con il seguente percorso C:\Program Files\Java\jre1.8.0_6

Anche su questo ho dei dubbi perché alcune cose, come il c 30, non sono reperibili attraverso i link del pdf o del tutorial (http://erika.tuxfamily.org/wiki/index.p ... os_diagram) e quindi le ho dovuti recuperare il "altri" modi.

Comunque dopo le varie istallazioni ho eseguito l'accesso, come amministratore, a scicoslab e istallato il file installer.sce.
Chiudo e riapro scicoslab per poi cambiare la working directory, attraverso il codice cd "C:\Program Files\scicoslab-4.4.1\contrib\scicos_ee\scicos_flex\dspic".
Apro scicos e da li apro l'esempio “pid_ctrl_codegen_udp_tuning_square_circle.cos”. Dal menu codegen clicco su FlexCodeGen e questa è la finestra che mi si apre:
Attachments
flexcodegen.png
flexcodegen.png (14.33 KiB) Viewed 8925 times

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Fri Nov 06, 2015 7:14 pm

Quindi con un indirizzo diverso da quello che viene indicato nell'esempio di compilazione. Quindi ho cercato all'interno della cartella SuperBlock la cartella workspace (che effettivamente c'è), e dentro questa la cartella ctrl_tuning (che invece non è presente). Quindi ho creato la cartella ctrl_tuning e ho inserito il seguente percorso C:\Program Files\scicoslab-4.4.1\contrib\scicos_ee\scicos_flex\dspic\SuperBlock_scig\workspace\ctrl_tuning.
Cliccando 'ok mi appare un messaggio "codegen error:Access denied! please, change directory or run ScicosLab with administrator privileges". Quindi ho riavviato Scilab come amministratore e rifatto il procedimento appena descritto. a quel punto mi appare questo messaggio:

Spero di non essere stato troppo prolisso e che mi possiate aiutare
Attachments
compiling error.png
compiling error.png (241.63 KiB) Viewed 8924 times

paolo.gai
Administrator
Posts: 875
Joined: Thu Dec 07, 2006 12:11 pm

Re: amazing ball_problema di compilazione

Post by paolo.gai » Fri Nov 06, 2015 10:02 pm

il primo problema se non sbaglio era dovuto al fatto che la dir. target è una dove l'utente non può scrivere.

questo è uno dei motivi per cui consigliamo l'installazione di scicoslab in c:\evidence\scicoslab

per quanto riguarda il compilatore, probabilmente hai scaricato un compilatore non supportato, il pacchetto è del 2011.

Paolo

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Sat Nov 07, 2015 3:51 pm

Ho apportato ora le modifiche che mi hai consigliato. Effettivamente il cambio di dir. target mi ha permesso di lanciarlo senza entrare come amministratore, e non so se quello o il "nuovo" compilatore, ma la compilazione è terminata con successo.

grazie.

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Sun Nov 08, 2015 1:56 pm

Dato che siete stati molto disponibili vi farei una seconda domanda. Nello step 4, quando collego la flex, attraverso il programmatore, al computer, la finestra MPLAB ICD si dovrebbe aprire automaticamente?

Penso anche sia rilevante che lavoro con MPLAB V8.92 e che uso un ICD 3.

paolo.gai
Administrator
Posts: 875
Joined: Thu Dec 07, 2006 12:11 pm

Re: amazing ball_problema di compilazione

Post by paolo.gai » Mon Nov 09, 2015 8:06 am

...no, devi far partire MPLAB IDE, configurare la porta usb come ICD3... e poi puoi programmare il dispositivo.

PJ

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Tue Nov 10, 2015 5:53 pm

Ok, ma collegando il programmatore alla flex sulla pagina di MPlab, dedicata all'icd 3, mi appare il seguente errore.
Attachments
icd3error.png
icd3error.png (12.19 KiB) Viewed 8905 times

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Tue Nov 10, 2015 5:55 pm

Ho già provveduto a settare il giusto modello di pic (dsPIC33FJ256MC710).

paolo.gai
Administrator
Posts: 875
Joined: Thu Dec 07, 2006 12:11 pm

Re: amazing ball_problema di compilazione

Post by paolo.gai » Tue Nov 10, 2015 6:11 pm

succede quando o il debugger è collegato male, o mplab ide è configurato con il micro sbagliato (ma sta leggendo 0 quindi non è il caso). la board è alimentata?

PJ

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Tue Nov 10, 2015 6:17 pm

La board è alimentata. Mi chiedevo se ho interpretato bene quello che c'è scritto nel tutorial e se la "parte superiore", quella che controlla i servo, debba rimanere collegata alla flex ?

paolo.gai
Administrator
Posts: 875
Joined: Thu Dec 07, 2006 12:11 pm

Re: amazing ball_problema di compilazione

Post by paolo.gai » Tue Nov 10, 2015 6:28 pm

quando il debugger fornisce un device id a 0 significa che non riesce a "vedere" il micro. è possibile che i jumper sulla scheda base non siano messi bene oppure che il micro sia bruciato o che il debugger non sia connesso bene.

PJ

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Wed Nov 11, 2015 12:01 am

Non vorrei sembrare insistente. Ma l'oggetto che sto utilizzando è in mio possesso solo da una settimana e non so il suo trascorso. In più non ho trovato delle informazioni valide sulla posizione dei jumper. Quindi io vi posterei una foto dell'oggetto in questione e vi chiedo anche se il problema può essere causato dalla mancanza di alcuni driver della usb?

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Wed Nov 11, 2015 12:18 am

scusate se uso due messaggi ma pensavo erroneamente di averla allegata nel primo.
Attachments
flex.png
flex.png (1.43 MiB) Viewed 8891 times

paolo.gai
Administrator
Posts: 875
Joined: Thu Dec 07, 2006 12:11 pm

Re: amazing ball_problema di compilazione

Post by paolo.gai » Wed Nov 11, 2015 8:19 am

Si tratta della flex light --> per cui i jumper non dovrebbero cambiare il comportamento del connettore di debugging.

Per caso provieni dal Lab Retis a Pisa?

Ciao,

Paolo

bongini89
Newbie
Posts: 14
Joined: Fri Nov 06, 2015 12:09 am

Re: amazing ball_problema di compilazione

Post by bongini89 » Wed Nov 11, 2015 10:44 am

No studio all'università di Firenze. Quindi l'assenza di driver non può essere la causa del mancato funzionamento?

Locked