Programming flash for AURIX TC397

Forum related to ERIKA Enterprise and RT-Druid version 3

Moderator: paolo.gai

Post Reply
Revertigo
Newbie
Posts: 2
Joined: Sun Aug 02, 2020 9:54 am

Programming flash for AURIX TC397

Post by Revertigo » Wed Aug 05, 2020 12:27 pm

Hello,
I have TriCore TC397XE board and i successfully managed to build demo application based on HighTec's free Tricore toolchain.
I can't debug the application on my board since both TRACE32 and winIDEA requires external hardware product (like PowerDeubg - http://www.bwz.se/nohau/UserFiles/Files ... erbach.pdf) in order to debug Erika app.
This means the only option left for me right now is to program the application to the infineon's internal flash. I converted the erika3app.elf into hex file and tried to program it using Infineon's memtool. I received the following warning:
warning.png
warning.png (30.27 KiB) Viewed 3957 times
I ignored it and tried to program the flash anyway, but the RST led became red, which points on a problem.
I will mention that i manged to program hex files which were created from executable within HighTec(IDE) and AURIX Development Studio. I can add additional information if something isn't clear.
Any suggestions on how to run my demo application ?

Thx, Dekel

e.guidieri
Full Member
Posts: 166
Joined: Tue May 10, 2011 2:05 pm

Re: Programming flash for AURIX TC397

Post by e.guidieri » Mon Aug 10, 2020 9:27 am

Hi,

I never worked with the memtool of Infineon so I cannot be much helpful about it, you should ask the infineon board about the warning.

The only think that I know it's that ERIKA's linker scripts for TC397x uses BootModeHeaders that are different from the ones that are flashed in the MCU at the factory. So the first time that you flash a new board with ERIKA you should use the following option.

Code: Select all

EE_OPT = "OSEE_TC_LINK_BMHD";
TriCore special EE_OPTs

Regards,

Errico

Revertigo
Newbie
Posts: 2
Joined: Sun Aug 02, 2020 9:54 am

Re: Programming flash for AURIX TC397

Post by Revertigo » Thu Aug 13, 2020 3:49 pm

Hi !
I tried to add this option into conf.oil file as you suggested but unfortunately i got the same results. The wired thing is that this warning pooped up also when i successfully managed to program .hex file using AURIX Development Studio (and everything worked well).
I'm probably doing something else wrong (i tried program few EE demos).
Thank you,
Dekel

Post Reply