Button Compilation problems using Scicoslab-pack-9.3

A forum useful to discuss the details of the ScicosLab code generator.

Moderator: paolo.gai

Locked
npascher
Newbie
Posts: 23
Joined: Mon Aug 31, 2009 12:25 pm

Button Compilation problems using Scicoslab-pack-9.3

Post by npascher » Fri Nov 05, 2010 5:48 pm

Hey all,

I have a problem, when I try to compile a scicoslab diagram containing a "flex_daughter_button" I get the following error message:

.\libee.a(flex_daughter_button.o)(.text+0x6c): In function `flex_daughter_button':
f:\Evidence\eclipse\plugins\CO867A~1.201\ee_base\contrib\scicos\src\pic30\flex_daughter_button.c:37:
undefined reference to `EE_button_S1_init'
.\libee.a(flex_daughter_button.o)(.text+0x70):
f:\Evidence\eclipse\plugins\CO867A~1.201\ee_base\contrib\scicos\src\pic30\flex_daughter_button.c:38:
undefined reference to `EE_button_S2_init'
make: *** [pic30.cof] Error 1


Does anybody know, how to fix this issue?

Regards

Niko

erikadds
Newbie
Posts: 45
Joined: Wed May 12, 2010 9:41 am

Re: Button Compilation problems using Scicoslab-pack-9.3

Post by erikadds » Tue Nov 09, 2010 10:14 am

Dear Niko,
thank you for reporting the bug.
To solve this problem, you need to update EE kernel using the nightly builds available from 8 November 2010 or later...
Your application will compile without errors.
Regards.

Dario
Evidence Srl

npascher
Newbie
Posts: 23
Joined: Mon Aug 31, 2009 12:25 pm

Re: Button Compilation problems using Scicoslab-pack-9.3

Post by npascher » Tue Nov 09, 2010 11:59 am

Thanks for reply and fixing, now it is working properly.


Regards Niko

paolo.gai
Administrator
Posts: 864
Joined: Thu Dec 07, 2006 12:11 pm

Re: Button Compilation problems using Scicoslab-pack-9.3

Post by paolo.gai » Fri Nov 19, 2010 4:27 pm

Hi Niko!

nice to hear the problem has been fixed.

We are currently working on making regression tests on the Scicos blocks... hopefully when they will be done we'll be able to rpevent this to happen!

Ciao,

PJ

Locked