missing seperator during project build.

Forum related to ERIKA Enterprise and RT-Druid version 2

Moderator: paolo.gai

Post Reply
Mangesh
Newbie
Posts: 4
Joined: Wed Oct 31, 2007 3:28 pm

missing seperator during project build.

Post by Mangesh » Thu Nov 08, 2007 5:06 pm

Hi,

When i try to build a project using one of the templates provided by RT-Druid, i get the following message:
deps:1: *** missing separator and the build stops.

I am using a previously installed cygwin on my machine. Could this be the problem ?

Thanks
Mangesh.

Romano
Newbie
Posts: 5
Joined: Wed Oct 31, 2007 5:32 pm

Re:missing seperator during project build.

Post by Romano » Fri Nov 09, 2007 4:20 pm

To solve the problem you have to go in the menu
Windows->Preferences
Then RT-Druid
OIL Pic30 configurator and set
Use EE Gcc to resolve dependencies
Use EE Gcc to compile

paolo.gai
Administrator
Posts: 864
Joined: Thu Dec 07, 2006 12:11 pm

Re:missing seperator during project build.

Post by paolo.gai » Sun Nov 11, 2007 10:01 am

Exact :-)

The problem is related to the fact that probably you have an expired license of the C30 student compiler.

When the license is expired, the compiler prints out a message on standard output.

Erika uses the option of the gcc compiler to generates the dependency files, which outputs to standard output.

When you compile with an expired license, then the expired license message simply corrupts the compiler output :-( ...

The issue can be solved using the C30 compiler recompiled from microchip sources (currently of the series 2.0x)

Bye,

PJ

Post Reply