Erika OS and AVR8

Forum related to ERIKA Enterprise and RT-Druid version 2

Moderator: paolo.gai

Post Reply
dimolin
Newbie
Posts: 18
Joined: Thu Feb 16, 2017 4:58 pm

Erika OS and AVR8

Post by dimolin » Sun Feb 19, 2017 4:35 pm

Hello,

I'm trying to run Erika OS on AVR8. I downloaded ERIKA Enterprise and RT-Druid 2.7.0, Windows 64bit version, unzipped it in C:/Evidence. Then installed AVR GCC compiler and Cygwin. In Elcipse/Windowa/Preferences I have pointed the paths to the compiler and cygwin. I created very simple OIL configuration.

CPU mySystem {
OS myOs {
EE_OPT = "DEBUG";
CPU_DATA = AVR8 {
APP_SRC = "main.c";
MULTI_STACK = FALSE ;
};
MCU_DATA = MEGA {
MODEL = MEGA_328p;
};
};

TASK Task1 {
PRIORITY = 1;
STACK = SHARED ;
SCHEDULE = FULL ;
};

TASK Task2 {
PRIORITY = 2;
STACK = SHARED ;
SCHEDULE = FULL ;
};
};

The compilation was successful. But now I don't know how to proceed. I cannot find the “Erika Enterprise Tutorial for the AVR microcontrollers”. Would you give some advice?

BR
Dimo

paolo.gai
Administrator
Posts: 864
Joined: Thu Dec 07, 2006 12:11 pm

Re: Erika OS and AVR8

Post by paolo.gai » Mon Feb 20, 2017 9:20 am

Hi!

Thanks for spotting this in the wiki. I have just updated it. The tutorial was moved to a wiki page longtime ago, but the reference remained there. The correct link is:

http://erika.tuxfamily.org/wiki/index.p ... on_Windows

Note the content may be old.

In general once you compiled the application, you should load the binary into the programmer for flashing it. Each architecture has its own tool to do that (the page above was detailing the steps for the AVR Studio).

Ciao,

PJ

dimolin
Newbie
Posts: 18
Joined: Thu Feb 16, 2017 4:58 pm

Re: Erika OS and AVR8

Post by dimolin » Tue Feb 21, 2017 10:35 am

Thank you, Paolo!

Unfortunately the link's content is obsolete and doesn't help me. But I think I found my problem. In the oil file I have missed the option KERNEL_TYPE = ECC2;. Without this option the project builds but when I tried to add task definitions in the code the project build crashed with strange error messages. But now I have a start point from which I can continue further.

Thank you again and best regards!
Dimo

dimolin
Newbie
Posts: 18
Joined: Thu Feb 16, 2017 4:58 pm

Re: Erika OS and AVR8

Post by dimolin » Thu Mar 09, 2017 2:35 pm

Hello,

I'm using JTAGICE3 and the latest AVR Studio to debug. I have problems with breakpoints. I get this message:

"The breakpoint will not currently be hit. Unable to set requested breakpoint on target. Note: The current selected device is unable to set breakpoint during runtime."

I'm using atmega328P.

Does anybody know the reason for that?

BR
Dimo

Post Reply